https 证书 certbot-auto执行错误

报错:
ImportError: /root/.local/share/letsencrypt/lib/python2.7/site-packages/cryptography/hazmat/bindings/_openssl.so: undefined symbol: OPENSSL_sk_num

解决方法:

 

原文链接:http://www.cnblogs.com/vaal-water/p/6375385.html

xl2tpd centos7 搭建,纯学习

这个并不是我一个人需要,所以我也没有从头开始研究

感谢 http://www.stunnel.info所写的文章及他的github代码:https://github.com/travislee8964/L2TP-VPN-installation-script-for-CentOS-7/

底部下载的源码里作者信息,我并没有更改,还是源作者的,我只是添加了epel源,修改了几处不兼容的地方

使用这份源码,表示新手使用起来可能会有些问题使用,因为centos官方源里并没有xl2tpd 这个软件。若原作者觉得不妥可联系: lovewy123@gmail.com 说明

先要添加epel:

要使用iptables,是需要iptables和iptables-service的

大概的改变就是这么多,另外有些小的配置修改,有兼容问题,或者部分处理有问题就不多说

本人修改后的源码下载:点击下载

近来挻忙

近来挻忙的,网络也各种抽风

最开始用的一香港vps,发现网络是不错,就是贵了点,再用下去估计得睡大街了。后来用softlayer,网络更快了,价格比之前的还便宜一些。可能树大招风,电信上海骨干网络死活不让softlayer的IP好过,隔几秒钟让你断一次,悲催。MTR看了,确定是上海电信骨干网络问题。目前来看,香港的vps网络带宽大的基本上被盯死了,带宽小的网络比较畅通,建议不购入香港的 vps。

这个周末,闲一点,换了服务器,更新了PHP,Nginx

PHP换到了7.0.1版本,Nginx换到了1.8

不得不说 ,PHP7.x确实快了许多,兼容性嘛,基本上没什么大问题,PHP 7是一个大改版本,但又兼容了老的版本这是比较好的,没有步Python的后尘。Python很不错,可惜了现在搞出来两个不兼容的版本,蛋疼…

Nginx目前最稳定的版本就是1.8了,不过下个版本1.9.x就不支持spdy而支持http2了,大家常用的nginx功能就那么几个,除非有特殊的需求才会去编译一个新版本,基本上1.8也能满足了

另外周末还发现一个问题,Filezilla连接SSL服务器,不管你的证书是不是CA认证过的,通通弹个框出来让你确定,特么敢情压根没判断证书啊,好不爽